This is related to Is it acceptable to ask questions about Drupal 8 after feature freeze? but I think it is worthwhile to split out into a separate question.

Some of you may know that Drupal 8 feature freeze was extended to February 18, 2013 (as of 11/30/2012). There have been a few discussions here about whether we should be accepting Drupal 8 related questions.

A related topic hasn't been mentioned, though. Are we, as a community, ready to answer questions about Drupal 8.

MPD, dude, it's Friday night. I'm tired. What does "ready" mean?

By "ready", do we have enough members working with Drupal 8 that we can actually answer questions? Having unanswered questions isn't good for the health of the site?

So, are you ready to answer Drupal 8 questions?

share
add comment

4 Answers

I agree with MPD that there are few people who are using Drupal 8 on an everyday basis, except those people involved in the development of Drupal 8 in some degree. I don't expect answers from those people, though, as I imagine Drupal 8, and their work, take most of their time.

Apart the fact that Drupal 8 is still evolving, and that libraries are still being included (Guzzle has been included in one of the recent commits), the most important issue I see so far is that Drupal.org API has problems parsing Drupal 8 code to build the documentation pages. (I remember I read a issue report on Drupal.org, probably on the Drupal.org webmasters queue, but I have also noticed the issue myself.)
If you look at CronController.php, you will notice the source code is not shown, while that file is not empty.

screenshot

/**
 * @file
 * Definition of Drupal\system\CronController.
 */

namespace Drupal\system;

use Symfony\Component\HttpFoundation\Response;

/**
 * Controller for Cron handling.
 */
class CronController {

  /**
   * Run Cron once.
   *
   * @return Symfony\Component\HttpFoundation\Response
   *   A Symfony response object.
   */
  public function run() {
    // @todo Make this an injected object.
    drupal_cron_run();

    // HTTP 204 is "No content", meaning "I did what you asked and we're done."
    return new Response('', 204);
  }
}

This means that when searching for CronController, Drupal.org API will show you a link to the CronController.php file, which then doesn't show any code.

screenshot

While having few people who are working with Drupal 8 code, or who are testing Drupal 8 in some way, means the answer for a Drupal 8 question could come after months, the fact we are not always able to provide a link to a documentation page for a class/method/function limits in someway the usefulness of the answers. It is true I could provide a link to a line of the Git repository, but the code that is found at that line changes when the file is edited, which means that such links would not anymore useful once the file is changed from a commit.

That it probably happen in very few cases, but to me ready to answer means having the right instruments for answering, and being able to link to the necessary function/method documentation is (IMO) indispensable for answering.
Having a computer running PHP 5.3.5 is not something difficult to get. Considering that PHP 5.3 is recommended also for Drupal 6, I would expect PHP 5.3 starts to be used to check the developed code. PHP 5.3 is also probably used from most of the host providers (the host provider I am using passed to PHP 5.3.13 right a month ago), and there should not be any reason to use PHP 5.2 for test sites, if not in the case the customers are still running PHP 5.2. Even in that case, there should be at least a computer running PHP 5.3.

share
    
Very good assessment. Having a computer running PHP 5.3.5+ is easy, but servers are a different story. For example CentOS is still on 5.3.3. I think this applies to other RHEL variants, too. –  MPD Dec 1 '12 at 23:02
    
I guess it depends from the company. My host provider passed to PHP 5.3 only recently, but it passed straight from PHP 5.2.x to PHP 5.3.13. I guess that it's a company's policy that decides which developers can enable a web server on their own computer, and which PHP version they should use. My point is that it is easier to install a new PHP version than to fix the issue with Drupal.org API for which we don't have any control on the server configuration. –  kiamlaluno Dec 1 '12 at 23:51
    
By the way, while the requirements page says Drupal 8 requires at least PHP 5.3.5, update.php reports an error if PHP is older than 5.3.3, which says, "Your PHP installation is too old. Drupal requires at least PHP 5.3.3. See the <a href="http://drupal.org/requirements">system requirements</a> page for more information." –  kiamlaluno Dec 2 '12 at 1:36
    
It is definitely 5.3.5 now, and there is the real possibility of going higher. The install does a version check; I suspect update hasn't been patched yet. Check out drupal.org/node/1751100 There is also a breakdown of the distros that are problematic. As I work on a bunch of different offices/machines, all of my dev work is done on remote servers so I always have access to everything. I ended up doing with CentOS+IUS. –  MPD Dec 2 '12 at 1:47
    
It seems the minimum version is going to be PHP 5.3.10. That issue doesn't have any patch, yet. I guess patching the update.php file should be done there. –  kiamlaluno Dec 2 '12 at 2:02
add comment

I don't think it's possible for anyone to be ready to answer D8 questions yet, except for maybe in the broadest sense (e.g. Q: Will there be core handling for media breakpoints in D8? A: Yes. Q: Did hook_menu() survive? A: Nope, it's dead in favour of a proper routing system).

I think Kiamlaluno makes a great point that those involved deep enough to be able to answer the more technical question at this point simply won't have time to. The rest of us have to wait until the codebase becomes a bit less volatile before we can answer with any authority.

Just my two cents :)

share
add comment

MPD, dude, I'm glad you asked this question.

I finally (as of 11/30) got a server built with a PHP version that will support Drupal 8.

Right now, I do not have the bandwidth at work to dedicate time to Drupal 8. I will be able to justify this as the actual launch date for Drupal 8 approaches. We (as in my employer) are pretty conservative as far as software versions go, as dealing bugs in third-party code eat into our budgets and spend precious time. We didn't officially start working on a Drupal 7 for a client until several minor versions had passed.

I do have a Drupal 8 instance going, and will be monitoring what is going on, though I am not sure how much personal time I will be able to dedicate to it right now. That said, I am contemplating creating a real, yet "expendable", public website based on Drupal 8 so I can experiment with features as them become more mature.

So, my answer is that I don't know if I will be able to answer Drupal 8 questions at the same level that I can answer questions about Drupal 7 and earlier.

share
add comment

I visit the site from time to time. I have seen others too. Not sure who 'we' are in this case, but... if there is an RSS feed, I could subscribe and perhaps once a day look at it. No promises.

share
    
'We' is just anyone who's kind enough to participate in the site and help to answer people's questions (your good self included) :). If you do have the time help out with this sort of thing that would be awesome obviously, I don't think any of us that aren't directly involved in core development can speak with much authority until next year at the earliest. But do correct me if that sounds wrong. –  Clive Dec 12 '12 at 10:46
    
There's an RSS feed for the 8 tag, but I think it'll be fairly slow in filling up for the time being –  Clive Dec 12 '12 at 10:47
    
Added to the Live RSS extension right next to the core RTBC patches feed :) –  chx Dec 14 '12 at 18:40
    
Awesome, thanks very much :) –  Clive Dec 17 '12 at 14:12
    
Guys, you are closing D8 questions so fast I can't answer them and some of them should be answered! How do I contest a close? –  chx Feb 20 '13 at 8:06
    
There's a link on each question labelled 'flag', click that and put a custom reason in - but if you want to just give me the link to the question(s) in question I'll re-open them. We're in a limbo with D8 questions at the moment (as you know), but if you say they can be answered that's good enough for me, I'll start being more lenient and ask the other mods to do the same –  Clive Feb 20 '13 at 8:45
    
Wouldit be this one: drupal.stackexchange.com/questions/62854? The only other recent one (drupal.stackexchange.com/questions/62855) is low quality and would have been closed for other reasons even if Drupal 8 had already been released. But let me know –  Clive Feb 20 '13 at 8:48
add comment

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .